Voice control & multi-functional instrument panel fault?

Discussion in 'ICE, Nav, Apps and other tech stuff' started by Johnny Grabble, Jun 19, 2017.

  1. Johnny Grabble
    Offline

    Johnny Grabble Site Supporter

    Joined:
    Sep 7, 2015
    Messages:
    319
    Likes Received:
    163
    Location:
    Cheshire
    Ratings:
    +211 / 0 / -0
    Drove to the airport on Saturday very early for a weekend trip away. It was light enough for no lights and the MFIP was showing the daylight (white characters) display as per picture below.

    1.jpg

    On arriving at the airport about half an hour later, while still driving at 20-25mph, the MFIP briefly went totally blank (dark), then no more than a second later it went completely and uniformly white for an instant, then briefly adopted the night time display (all characters orange) before resuming back to the daylight display. Parked undercover, as I didn’t want a roasting hot car upon my return.

    Driving from the airport back home on Sunday, early evening, the MFIP was fine. However, I tried to access the voice control system using the button on the steering wheel. A message came up on the HUD with words to the effect of “voice control system not available, will be available in a minute”. I’ve seen this before when I tried to use the system immediately after starting the car, so I assumed it was the system requiring some boot up time. I therefore left it for 10 minutes and tried again. Same result, voice control not available. This persisted for the entire journey home, about 45 minutes in all. Got home and parked up. Later that evening, I went out to the car, opened at started it and the voice control system was available to me within about 10 seconds of starting the engine.

    I’m wondering if this is the onset of an intermittent electrical connection fault. Some time ago, back in 2015, I had the iDrive show “NO SIGNAL” in red letters on the display and then last summer the iDrive switched off and rebooted itself while I was driving. Although the car is still under warranty until sometime next year, I just know what the dealer will say if I turn up there with an intermittent electrical fault…

    Wondered if anyone else has had a similar experience and if so, what did you do?
     
  2. kleynie
    Offline

    kleynie WARLORD Site Supporter

    Joined:
    Aug 4, 2015
    Messages:
    3,202
    Likes Received:
    713
    Location:
    Staines, Middlesex
    Ratings:
    +1,168 / 1 / -0
    Could this be the first sign of the battery dying? I used to get all manner of strange things happening on my old GT when the battery was on its way out. I kept it alive with a C TEK conditioner until I px'ed it at four year old.
     
  3. Johnny Grabble
    Offline

    Johnny Grabble Site Supporter

    Joined:
    Sep 7, 2015
    Messages:
    319
    Likes Received:
    163
    Location:
    Cheshire
    Ratings:
    +211 / 0 / -0
    Shouldn't be battery I would've thought, the car averages over 50 miles a day and it's just over 2 years old. There's 12.5V available on a cold start and the alternator charges at ~14V. Another one of our cars, also stop-start, does <3,000/year and at 3 years old the battery is just starting to require some occasional help from the C-TEK.
     
  4. Mieke
    Offline

    Mieke WARLORD Site Supporter

    Joined:
    Sep 8, 2015
    Messages:
    1,299
    Likes Received:
    389
    Location:
    Cheshire
    Ratings:
    +771 / 2 / -0
    Last edited: Jul 3, 2017
  5. slim_boy_fat
    Offline

    slim_boy_fat WARLORD Site Supporter

    Joined:
    Jul 31, 2015
    Messages:
    2,203
    Likes Received:
    688
    Ratings:
    +1,113 / 1 / -0
    It must be incredibly frustrating when all this high tech goes on the blink [I'm glad my old e60 doesn't have too much of it].

    Makes me want to find a good Triumph Herald.......:D
     
  6. Peter
    Offline

    Peter WARLORD Site Supporter

    Joined:
    Aug 5, 2015
    Messages:
    1,116
    Likes Received:
    516
    Location:
    Highland Region
    Ratings:
    +763 / 0 / -0
    The welding kit will come in handy! ;)

    You are right about the tech, my comfort assess needs fixing, will hopefully find out what it is this week. As if central locking isn't complicated enough when it goes wrong.

    Peter
     
    • Agree Agree x 1
  7. Postman
    Offline

    Postman

    Joined:
    Aug 24, 2015
    Messages:
    92
    Likes Received:
    20
    Ratings:
    +37 / 0 / -0
    Different marque I know but ....... wife's Lexus has all singing dancing interactive crap on it ( pity it doesn't have a decent engine). However every now and again the map DVD refuses to read the disc, and when this happens the voice activation etc plays up, and that includes all the functions not obviously related to the map display e.g. phone and climate controls.
     
  8. Mieke
    Offline

    Mieke WARLORD Site Supporter

    Joined:
    Sep 8, 2015
    Messages:
    1,299
    Likes Received:
    389
    Location:
    Cheshire
    Ratings:
    +771 / 2 / -0
    That's the trouble with putting computers into cars. You have to expect a few glitches and crashes. ;)
     
  9. slim_boy_fat
    Offline

    slim_boy_fat WARLORD Site Supporter

    Joined:
    Jul 31, 2015
    Messages:
    2,203
    Likes Received:
    688
    Ratings:
    +1,113 / 1 / -0
    Aye, and you can hardly switch it off and do a reboot when you're at 70 on the M6..........:p
     
    • Funny Funny x 1

Share This Page